Отображение выбранного периода в управляемой форме 1С 8.2

Новая платформа 1С Предприятие 8.2 получает все большее распространение, некоторые аспекты разработки прикладных решений на этой платформе существенно отличается от предыдущих версий 8.0 и 8.1. В большей степени изменения коснулись принципов построения пользовательского интерфейса, изменилась как сама концепция построения интерфейса, так и способы работы с ним, причем как для разработчиков так и для пользователей. Реализацией этой новой концепции является так называемый “управляемый интерфейс”, в основе которого лежат управляемые формы, которые кардинально отличаются от старых “обычных” форм, применяемых в предыдущих версиях платформы. Нередко, приемы и концепции программирования, которые замечательно работали для обычных форм, оказываются совершенно не применимы в управляемых формах. Эта статья открывает серию статей, которая посвящена разработке в новой платформе 1С 8.2. Статьи серии будут организованы про принципу FAQ, т.е. проблема-решение.

В форме списка документов есть возможность выбрать период, но выбранный период не отображается на форме, что очень неудобно. Как его отобразить на форме?

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПодключитьОбработчикОжидания("ОтобразитьПериод", 1);
КонецПроцедуры

&НаКлиенте
Процедура ОтобразитьПериод()
	Период = Элементы.Список.Период;
	ДатаНачала = Период.ДатаНачала;
	ДатаОкончания = Период.ДатаОкончания;
	Если ДатаНачала='00010101' И ДатаОкончания='00010101' Тогда
		Заголовок = "Весь период (без ограничения)";
	Иначе
		Заголовок = Строка(Период.Вариант) 
			+ " (" + Формат(ДатаНачала,"ДФ=dd.MM.yyyy") 
			+ " - " + Формат(ДатаОкончания,"ДФ=dd.MM.yyyy") + ")";
	КонецЕсли;
КонецПроцедуры

Если публикация показалась Вам полезной и интересной не забывайте оставлять свои отзывы и комментарии, так же Вы можете выразить свою благодарность материально.

Комментарии:

  1. Валим пишет:

    Спасибо. Работает!

  2. Прохожий пишет:

    ПредставлениеПериода()

  3. Александр пишет:

    Спасибо.

Оставить комментарий