PostgreSQL для Windows сборка от 1С. Решение проблемы pgAdmin4: the application server could not be contacted

Многие пользователи, которые устанавливали сборку PostgreSQL для Windows от фирмы 1С сталкивались с проблемой запуска версии pgAdmin4, которая идет в комплекте с данной сборкой. А именно, запуск pgAdmin4 завершался ошибкой “the application server could not be contacted” Конечно можно установить свежую версию pgAdmin4 с официального сайта https://www.pgadmin.org/download/pgadmin-4-windows/ и она будет работать без проблем.
Тем не менее, версию из дистрибутива 1С также можно запустить. Проблема кроется в том, что специалисты из 1С осуществляющие сборку этого дистрибутива почему-то забыли включить в него пакет backports. Причем делают они это с завидной регулярностью, повторяя эту ошибку от релиза к релизу. Для решения проблемы достаточно скачать пакет backports.csv-1.0.7.tar.gz самостоятельно с официального сайта Python https://pypi.org/project/backports.csv/#files извлечь из архива папку backports(содержащую два файла) и поместить её в “Папка установки PostgreSQL\pgAdmin 4\venv\Lib”

Если публикация показалась Вам полезной и интересной не забывайте оставлять свои отзывы и комментарии, так же Вы можете выразить свою благодарность материально.

Оставить комментарий