HTML – это просто: Программное формирование HTML-документа, содержащего ссылки на объекты базы данных 1С. Часть II

Данная статья является развитием статьи «HTML – это просто: Программное формирование HTML-документа, содержащего ссылки на объекты базы данных 1С. Часть I», в ней рассматривается наиболее гибкий и в то же время простой способ формирования HTML-документа, содержащего ссылки на объекты базы данных 1С. Как выяснилось, в ходе обсуждения предыдущей статьи на форуме сообщества Infostart.ru, существует и более простой способ формирования ссылки на объект БД:

Процедура ДобавитьТекстHTML(ТекстHTML, Элемент);
    СсылкаНаЭлемент = ЗначениеВСтрокуВнутр(Элемент);
    ТекстHTML.ДобавитьСтроку("<A href= " + "v8:"+СсылкаНаЭлемент
    + ">"+Элемент+"</A><BR>");
КонецПроцедуры  

Процедура ДействияФормыСформировать(Кнопка)
    Запрос = Новый Запрос("
    |ВЫБРАТЬ
    |    Номенклатура.Ссылка
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура");
    ТекстHTML = Новый ТекстовыйДокумент;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        ДобавитьТекстHTML(ТекстHTML, Выборка.Ссылка);
    КонецЦикла;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(ТекстHTML.ПолучитьТекст());
КонецПроцедуры

Процедура ПолеHTMLДокументаonclick(Элемент, pEvtObj)
    // Отказ от стандартной обработки клика.
    pEvtObj.returnValue = Ложь;
    Если ВРег(pEvtObj.srcElement.tagName) = "A" Тогда
        СсылкаТекст = Сред(pEvtObj.srcElement.href, 4);
        Ссылка = ЗначениеИзСтрокиВнутр(СсылкаТекст);
        Если Ссылка.Пустая()
        Или Ссылка.ПолучитьОбъект() = Неопределено Тогда
            Предупреждение("Ошибка открытия объекта.",, "Ошибка");
            Возврат;
        Иначе
            ОткрытьЗначение(Ссылка);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Скачать обработку

Если публикация показалась Вам полезной и интересной не забывайте оставлять свои отзывы и комментарии, так же Вы можете выразить свою благодарность материально.

Оставить комментарий